Вот такая ошибка после portupgrade php5-spl до версии 5.2.8.

Решение:

cd /usr/ports/lang/php5

make deinstall && make clean

make install

cd /usr/ports/devel/php5-spl

make deinstall && make clean

make install

Проблема в том что для правильной инсталяции php5-spl нам нужно пересобрать php5 (удалить и установить заново)